[rancid] duplicated characters (SOLVED)

Corey Edwards tensai at zmonkey.org
Mon Sep 26 15:48:51 UTC 2011

On 09/20/2011 10:25 AM, john heasley wrote:
> Thu, Sep 15, 2011 at 09:52:33AM -0600, Corey Edwards:
>>> either way, if you can capture clogin -d -c 'show running' o/p where this
>>> occurs, it should at least reveal where the bug is.
>> I captured this output, but unfortunately it was rife with passwords. I
>> trimmed it down to what I hope is still a useful summary. In this
>> example the duplicated character showed up in the word "permitt".
>> http://pastebin.com/epUCPr2p
> -expect: does "access-list 1 permit x.x.x.101\r\naccess-li" (spawn_id exp6) match regular expression "\u0008+"? (No Gate, RE only) gate=yes re=no
> +expect: does "access-list 1 permitt x.x.x.101\r\naccess-l" (spawn_id exp6) match regular expression "\u0008+"? (No Gate, RE only) gate=yes re=no
> its occuring inside tcl or expect.  i suspect its the same problem that i
> had with hpuifilter when some linux users started upgrading.  I dont know
> what the cause is, but i'd look for old versions of libc and internationization
> libraries that tcl or expect are linked with.

I ran clogin through strace and looked at all the files that were
touched. A comparison between the working server and the upgraded server
revealed some kerberos packages (libkrb5-dev, krb5-config,
krb5-clients). After removing those, everything is working perfectly. I
guess a kerberized version of telnet must have been triggering this bug.


More information about the Rancid-discuss mailing list